http://www.mysqlkorea.co.kr
한글매뉴얼 5.0 , 한글매뉴얼 5.1 , MySQL 5.1 HA , 사용자매뉴얼
공지사항  
뉴스  
질문과 답변
DBA
Developer
Cluster
토크박스  
이벤트  
서포트 티켓  
최신글
mysql 관련해서 …
이제 날씨가 가을…
killed 상태가 너…
mysql 백업/복구 …
apm 설치 헤메고…
 
질문과 답변 (DBA) > 커뮤니티 존 > 질문과 답변 (DBA)
myxql 관련 지원 OS문의드립니다.
글쓴이 : goblin   날짜 : 18-02-01 15:41   조회수 : 1064
centos에 mysql을 올리려고 하는데요

mysql 홈페이지에서 조회되는건 centos 6.x에서는 mysql 5.5이상 버전을 지원한다고 나와있는데

centos6.x를 설치할때 기본으로 설치되는 mysql이 5.1버전으로 설치가 되더라구요

centos6.x에서 설치되는 mysql5.1버전을 그냥 사용해도 문제가 되지 않는건지 궁금합니다

도움 부탁드리겠습니다
royster
5.1설치해도 될것. 같은데요
goblin
답변 감사합니다 하나만 더 여쭤볼게요 하려는 작업이 서버를 옮기는 작업이라 db를 이관해야되는데

xtrabackup 이용할경우에 마이너 버전이 다른 db간에 이관작업이면 문제 없이 가능할까요....??

같은 5.1버전인데 기존 버전은 5.1.58버전이고 이관하려는쪽은 5.1.73버전이라 가능한지 잘 모르겠어서요...
royster
버전 다운그레이드 라면 문제가 되지만 , 업그레이드이므로  상관없습니다.

다만  이관 완료 후  mysql_upgrade 유틸 실행하면 되겠습니다.
goblin
자꾸 질문드리는거같아 죄송한데....

혹시 xtrabackup으로 major버전이 다른경우에는 이관이 불가능한가요...??

5.0에서 5.6으로 올려보는거 테스트 해봤는데 mysql_upgrade유틸 실행하라고 에러나오면서 서버는 기동이 안되더라구요
royster
ver. 5.0 -> 5.6 으로 바로 업그레이드는 불가능 합니다.

5.0 -> 5.5 -> 5.6 순으로 순차적으로 업그레이드 실행하기 바랍니다.

자세한 내용은 MySQL 레퍼런스를 읽어보기바랍니다.
이전글 mysql bin로그 갱신시 슬로우쿼리 
다음글 MySQL 5.7에서 프로시저로 key/value 배열값으로 멀티 insert 처리하는 방법이 있을까요? 
MySQL Korea 사이트의 컨텐츠 소유권은 (주)상상이비즈에 있으므로 무단전재를 금합니다.
ⓒ 2010-2011 ssebiz All Rights Reserved.